Come contare le celle su Excel

In questa lezione ti spiego come contare le celle sul foglio Excel. Esistono diverse funzioni di conteggio, ognuna con le proprie particolarità.

=CONTA.NUMERI(x)

Conta soltanto le celle con valori numerici nell'intervallo x.

=CONTA.VALORI(x)

Conta le celle non vuote, quelle contenenti numeri, testo o altro nell'intervallo x.

=CONTA.VUOTE(x)

Conta soltanto le celle vuote nell'intervallo x.

=CONTA.SE(x;condizione)

Conta le celle nell'intervallo x che soddisfano una condizione.

=CONTA.PIU.SE(x1;condizione1;x2;condizione2)

Conta le celle nell'intervallo x1 che soddisfano due o più condizioni.

Nota. Il parametro x è l’intervallo di celle che vuoi contare. Nel caso della funzione CONTA.PIU.SE() devi indicare l'intervallo x1, x2, ... prima di ogni condizione. Gli intervalli possono anche coincidere.

Ti faccio un esempio pratico

Digita questi dati nell'intervallo B3:B11. Complessivamente sono nove celle di cui una vuota (B6).

digita alcuni dati

Digita la funzione =CONTA.NUMERI(B3:B11) nella cella D3.

digita =CONTA.NUMERI(B3:B11)

Questa funzione conta soltanto le celle contenenti dei numeri nell'intervallo B3:B11.

In questo caso ci sono 4 celle con valori numerici. Sono le celle B4, B5, B10 e B11.

il risultato è 4

Ora digita la funzione =CONTA.VALORI(B3:B11) nella cella D3.

digita =CONTA.VALORI(B3:B11)

Questa funzione conta tutte le celle non vuote nell'intervallo B3:B11

Il risultato è 8 perché ci sono otto celle contenenti testo, numeri o valori booleani.

il risultato è 8

Nota. La cella B6 del foglio di calcolo non viene contata dalla funzione =CONTA.VALORI() perché è una cella vuota.

Digita la funzione =CONTA.VUOTE(B3:B11) nella cella D3.

digita =CONTA.VUOTE(B3:B11)

Questa funzione conta solo le celle vuote nell'intervallo B3:B11

In questo caso il risultato è 1 perché c'è una sola cella vuota (B6).

il risultato è 1

Nota. Nel foglio di calcolo Excel una cella è vuota solo se non contiene nulla. Le celle che contengono una stringa vuota, ossia quelle che cominciano con l’apice ‘ senza essere seguite da altri caratteri, non sono considerate celle vuote.

Digita la funzione =CONTA.SE(B3:B11;">1") nella cella D3.

digita =CONTA.SE(B3:B11;">1")

La funzione conta solo le celle con valore maggiore di 1 nell'intervallo B3:B11.

Il risultato è 2 perché ci sono due celle che soddisfano la condizione (B5 e B10).

il risultato è 2

E per contare solo le celle che contengono il testo?

Per contare solo le celle che contengono testo, senza includere i numeri, le celle vuote e i valori booleani, puoi usare la funzione =CONTA.SE() indicando come condizione il carattere jolly ossia l’asterisco “*”

Ad esempio, digita la funzione =CONTA.SE(B3:B11;"*") nella cella D3.

digita =CONTA.SE(B3:B11;"*")

La funzione conta solo le celle che contengono testo nell’intervallo B3:B11

Il risultato è 2 perché ci sono due celle contenenti del testo (B7 e B8)

il risultato è 2

Per includere più condizioni usa la funzione =CONTA.PIÙ.SE()

Ad esempio, digita =CONTA.PIÙ.SE(B3:B11;"*";B3:B11;"<>A") nella cella D3.

digita =CONTA.PIÙ.SE(B3:B11;"*";B3:B11;"<>A")

La funzione conta solo le celle che soddisfano tutte le condizioni della selezione.

In questo caso le condizioni da rispettare sono due:

  • contengono testo
  • non contengono il testo “A”

Il risultato è 1 perché c'è solo una cella nell’intervallo B3:B11 contenente testo che non contiene "A". E' la cella B7.

il risultato è 1

Leggi tutte le lezioni del corso Excel di Nigiara




Non hai risolto il tuo problema? Scrivi una domanda




FacebookTwitterLinkedinLinkedin