Come usare la funzione SOMMA.SE() di Excel

In questa lezione ti spiego come utilizzare la funzione SOMMA.SE sul foglio Excel

=SOMMA.SE(int; cond; [int_somma])

A cosa serve?

Questa funzione ti permette di sommare dei valori del foglio Excel solo se è soddisfatta una condizione

La funzione =SOMMA.SE è composta da tre parametri

  • int
    è l'intervallo/area del foglio Excel dove verificare se la condizione è vera
  • cond
    è la condizione da verificare
  • int_somma
    è un'altra area del foglio Excel dove si trovano i valori da sommare (facoltativo)

Nota. L'ultimo parametro (int_somma) è facoltativo. Se non lo indichi, Excel somma i valori nell'intervallo che hai indicato nel primo parametro della funzione SOMMA.SE().

Ti faccio un esempio pratico

Digita una sequenza di numeri nell'intervallo B2:B5

digita una sequenza di numeri

Ora inserisci la funzione =SOMMA.SE(B2:B5;">0") nella cella B7

digita =SOMMA.SE(B2:B5;">0")

In questo caso la condizione è ">0" ossia i valori devono essere maggiori di zero.

la somma è uguale a 6

La funzione somma solo i valori maggiori di zero dell'intervallo B2:B5

$$ 1+2+3 = 6 $$

Il risultato della somma è 6

Nota. Il numero -4 nella cella B3 è stato escluso dalla somma perché non soddisfa il criterio di selezione. Non è un numero positivo.
il numero -4 non viene sommato

A cosa serve il terzo parametro?

Il terzo parametro della funzione =SOMMA.SE() ti permette di verificare il criterio di selezione su un intervallo del foglio e sommare i valori corrispondenti in un altro intervallo.

Ti faccio un esempio pratico.

Digita questa tabella con due colonne nell'intervallo B2:C5 del foglio Excel

digita questa tabella

Ora inserisci la funzione =SOMMA.SE(C2:C5;"=1";B2:B5) nella cella B7

digita =SOMMA.SE(C2:C5;"=1";B2:B5)

La funzione verifica quali valori sono uguali a 1 nell'intervallo C2:C5 e somma gli elementi corrispondenti nell'intervallo B2:B5

$$ 1+ 2 = 3 $$

Il risultato è 6.

la somma condizionata è uguale a 6

In questo caso la condizione viene controllata in una colonna (C) ma la somma è calcolata su un'altra colonna (B)

come funziona la somma condizionata

Nota. Il criterio di selezione con l'uguaglianza puoi anche scriverlo omettendo il simbolo uguale "=". Quindi, puoi scrivere =SOMMA.SE(C2:C5;"=1";B2:B5) con il carattere uguale oppure =SOMMA.SE(C2:C5;"1";B2:B5) senza il carattere uguale. Il risultato è sempre lo stesso.
digita =SOMMA.SE(C2:C5;"1";B2:B5)

Per completezza ti faccio un altro esempio pratico.

La condizione di selezione della funzione SOMMA.SE() funziona anche se i valori da controllare sono valori alfanumerici

Ad esempio, inserisci questa tabella

una tabella a due colonne

Ora digita la funzione =SOMMA.SE(C2:C5;"RM";B2:B5)

digita  =SOMMA.SE(C2:C5;"RM";B2:B5)

La funzione verifica quali celle nell'intervallo B2:B5 sono uguali alla stringa "RM" e somma i valori numerici corrispondenti nell'intervallo C2:C5

come funziona la somma condizionata

La somma condizionata è uguale a 4

il risultato della somma condizionata è uguale a 4

E' possibile fare la somma usando più criteri?

Per calcolare la somma condizionata con più criteri di selezione devi usare la funzione SOMMA.PIÙ.SE()

E' un'altra funzione del foglio Excel.

Leggi tutte le lezioni del corso Excel di Nigiara




Non hai risolto il tuo problema? Scrivi una domanda




FacebookTwitterLinkedinLinkedin