Come calcolare una serie su Excel

In questa lezione ti spiego come si calcolano le somme parziali di una serie matematica su Excel tramite la funzione SOMMA.SERIE()

=SOMMA.SERIE(x,n,m,c)

Questa funzione ha quattro parametri

  • x è la funzione della serie
  • n è la potenza iniziale della serie
  • m è l'incremento della di n per ciascun termine della serie
  • a è il coefficiente

Questa funzione permette di calcolare la serie matematica

$$ a_1 x^n + a_2 x^{n+m} + a_2 x^{n+2m} + ... $$

Dove x è la funzione che identifica il termine generale della serie.

A cosa serve una serie? Molte funzioni matematiche possono essere approssimate tramite il calcolo di una serie. La funzione SOMMA.SERIE() semplifica il calcolo della serie sul foglio Excel.

Ti faccio un esempio pratico.

Considera questa serie

$$ 2 x^2 + 5 x^2 + 8 x^2 + 4 x^2 + ... $$

Digita i primi quattro coefficienti della serie (2,5,8,4) nell'intervallo A2:A5

i coefficienti della serie

Poi digita l'indice della serie (1,2,3,4,...) nell'intervallo B2:B5

l'indice della serie

Nella cella C2 digita la funzione =SOMMA.SERIE(B2^2;1;0;A2)

il termine generale della serie

Ora copia la formula della cella C2 nell'intervallo C3:C5

copia la formula

Per ottenere la somma dei primi quattro termini della serie inserisci la funzione =SOMMA(C2:C5) nella cella C8

digita =SOMMA(C2:C5)

In questo modo hai calcolato la somma dei primi quattro termini della serie su Excel.

la somma della serie

Verifica. Se fai una rapida verifica a mano i calcoli sono corretti. $$ s_4 = 2 \cdot 1^2 + 5 \cdot 2^2 + 8 \cdot 3^2 + 4 \cdot 4^2 = 2 + 20 + 72 + 64 = 158 $$ Il quarto termine della serie è 158.

Per calcolare ogni termine della serie digita =C2 nella cella D2

Poi digita =D2+C3 nella cella D3

digita =D2+C3 nella cella D3

Infine, copia la formula nella cella D3 anche nelle celle sottostanti D4:D5

copia la cella D3 nell'intervallo D4:D5

In questo modo puoi vedere i primi quattro termini della serie ossia le somme parziali della serie

le prime somme parziali

Verifica. I primi quattro termini della serie (somme parziali) sono $$ s_1 = 2 $$ $$ s_2 = 22 $$ $$ s_3=94 $$ $$ s_4 = 158 $$

Ti faccio un altro esempio.

Il numero di Nepero e=2,718281828.... si ottiene tramite la serie matematica

$$ e = \sum_n=1^{\infty} \frac{n}{n!} =2,718281828 $$

Prova a calcolare i primi 5 termini della serie sul foglio Excel.

In questo caso tutti i coefficienti della serie sono uguali a 1

Quindi, digita i valori uguali a 1 nell'intervallo A2:A6

i coefficienti della serie

Poi inserisci l'indice dei primi cinque termini della serie 1,2,3,4,5 nell'intervallo B2:B6

l'indice della serie

Digita la funzione =SOMMA.SERIE(B2/FATTORIALE(B2);1;0;A2) nella cella C2

digita =SOMMA.SERIE(B2/FATTORIALE(B2);1;0;A2)

Poi copia la cella C2 nell'intervallo C3:C6

copia le celle

Infine inserisci la funzione =SOMMA(C2:C6) nella cella C8

digita =SOMMA(C2:C6)

La somma dei primi cinque termini della serie è 2,708333333

la somma della serie

Il risultato 2,708333333 è molto simile al numero di Nepero e=2,718281828

Nota. In questo caso hai calcolato solo i primi 5 termini della serie. Se aumenti il numero dei termini il risultato diventa più preciso, perché la somma parziale tende ad avvicinarsi sempre più al numero di Nepero. Ad esempio, se ripeti il calcolo sui primi 10 termini della serie la somma parziale è s10=2,718281526 ed è molto più vicina al numero di Nepero e=2,718281828
la somma parziale della serie dopo 10 termini

In conclusione, questa serie fornisce un'approssimazione del numero di Nepero.

Leggi tutte le lezioni del corso Excel di Nigiara




Non hai risolto il tuo problema? Scrivi una domanda




FacebookTwitterLinkedinLinkedin